ArcadeCollecting.com
Welcome, Guest. Please login or register.
December 16, 2019, 07:11:47 AM

Login with username, password and session length
Search:     Advanced search
Yay, a message board!
319 Posts in 114 Topics by 43 Members
Latest Member: deejaymc
* Home Help Search Login Register
+  ArcadeCollecting.com
|-+  General Category
| |-+  Gone but not forgotten
| | |-+  Bagman
« previous next »
Pages: [1] Print
Author Topic: Bagman  (Read 2798 times)
tim
Administrator
Full Member
*****
Posts: 166


View Profile
« on: May 04, 2007, 01:06:40 PM »

Company : Stern (developed by Valadon Automation)
Cabinet : Dedicated
Monitor : 19" vertical color raster



Info
I've been keeping my eye out for a Bagman because I wanted to play it with my hack installed (never really got to). Recently, one showed up on the local CraigsList but it was overpriced and not working. It looked like it was in really nice shape from the pictures, though.

I emailed them a lowball offer and didn't hear anything back. Then, three weeks later I got an email saying "we will sell. call us." I called and they gave me the address of an antique store. I drove there and picked it up for half of what they were asking.

Got it home and it wasn't working as advertised, but it had 116 quarters locked inside it. Score. Smiley I'm glad they didn't have the keys.

First thing I noticed was that the fuses were blown on the power supply. Tested the voltages on the test points and they were *all* messed up. Decided to swap in a standard modern switching power supply. Made a harness for the switcher and plugged it into the existing connectors and powered up. Nadda. Tested voltages and they were still all messed up. Decided to check the wiring and found that the harness was plugged into the PCB cage backwards. D'oh! No wonder the old supply blew it's fuses. Plugged it in the right way 'round (poor design that it's even possible to do that) and the game came up right away. A little adjusting to the monitor and some credits and it played great.

Only problem was that it had horrible, horrible hum bars. Tweaked the +5v adjustment on the power supply and the hum bars moved around, but didn't disappear. Cheap crappy power supply!! Decided to swap in a non-video game power supply which I had bought from a friend, Dale Luck (one of the original firmware developers for the Amiga) many years ago for $10 (bought six at the time). Only problem is the power connectors weren't labeled. So I used the DVM to find +5 and +12, but couldn't find a -5v, which Bagman needed for it's inputs to work. Hooked it up anyway to see if the hum bars were gone and they sure were! Smooth as silk!! Nice supply. Only bad thing is the game didn't actually boot. It was stuck on a screen full of garbage. Tested +5 and it was fine. Cycled power and it came up! Hmmm. Couldn't coin up without the -5v though. The supply had, like, 6 extra power connectors that weren't putting out any voltage, so I figured something was odd. Poked around with the DVM s'more and found that it had +12v and +5v supplies that were isolated from the others. I figured that meant they were designed to be either + or - voltages. Sure enough, if I connected ground to one side I could get -12v or -5v out of the other. That solved that.

However, the game still wouldn't boot on the first try with this supply. I looked up the pinouts for Bagman and found that there was a reset pin on the edge connector. I manually grounded that while on the garbage screen and the game started when I let go! That pin wasn't normally connected to anything, but what the heck -- I had a spare reset circuit laying around in case I ever needed to fix a MCR game or a Qix hardware game (those games have a circuit that resets the game once the +5v stablizes), so I wired the circuit into the harness and bingo! Game boots every time now.

Burned the ROMs for my hack and played me a bunch of Bagman. Was finally able to complete the first stage for the first time ever only to find the 2nd stage is identical to the first and the wheel barrow stays where you left it on the first. Booo! I don't think they expected anyone would ever clear the first stage. Damn hard game!!

Some day I'll have to see if I can hack it to play both Super and regular Bagman.
« Last Edit: May 04, 2007, 01:31:30 PM by tim » Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!