ArcadeCollecting.com
Welcome, Guest. Please login or register.
August 13, 2022, 08:19:04 PM

Login with username, password and session length
Search:     Advanced search
Yay, a message board!
319 Posts in 114 Topics by 43 Members
Latest Member: deejaymc
* Home Help Search Login Register
+  ArcadeCollecting.com
|-+  General Category
| |-+  Gone but not forgotten
| | |-+  Great Guns
« previous next »
Pages: [1] Print
Author Topic: Great Guns  (Read 3218 times)
tim
Administrator
Full Member
*****
Posts: 166


View Profile
« on: November 20, 2005, 02:20:21 PM »

Company : Stern
Cabinet : Dedicated
Monitor : 19" horizontal color raster



Info
Sometime in 2003, I saw a post on r.g.v.a.c. from my buddy Stephen Beall saying he was selling dedicated Lazarian and Great Guns cabinets. (Great Guns is a light gun game with two rifles mounted to the control panel.) He said the Great Guns did not work and he suspected a PCB problem from the symptoms. It was a pretty rare game and the pics he had showed it had neat artwork. So I emailed him and said that I'd take both cabs for his (low) asking price if he'd drop them off at my office in Valencia, CA. I told him I was in no hurry. He agreed.

From my work on MAME, I happened to know that Great Guns ran on similar hardware to Mazer Blazer. In fact, I happened to have a spare Mazer Blazer boardset. I secretly hoped that it would turn out to be working and be a straight ROM swap for Great Guns. Then I'd have a working Great Guns in no time flat. Unfortunately, neither turned out to be the case. Not only did the Mazer Blazer PCB turn out to be dead, but it was also slightly different than Great Guns, preventing a simple ROM swap. I told the author of the MAME driver about my find and he was enthusiastic about helping me to try to get the game working. Schematics were available and he was pretty familiar with the game after trying to get it working properly in MAME, so I set up AIM near the test bench and we started poking away at it. We identified several bad parts on the board that were preventing the game from passing its self tests and replaced them with good ones. This got the game all the way through its self tests but it still locked up right before it should have started displaying the attract mode. I was getting ready to move so I was hoping we could figure out the problem before I had to pack everything in boxes and load it on a truck. Unfortunately, we eliminated every problem we could think of that would cause this behavior but nothing fixed it. So in a box the boards went, where they continue to sit to this very day, waiting for me to get back around to tinkering with them.

In Feb 2009, I finally saw a PCB for sale on eBay which was advertised as tested, working. I didn't want to miss this since I had been looking for a working PCB for more than three years, so I emailed him a very high offer to end the auction early and sell to me. The greedy bastard asked for even more but I didn't have much choice so I accepted. He took what seemed like forever to send it and when it finally arrived, guess what? It didn't work.

Fortunately, I quickly tracked the problem down to a dead Z80, which was a simple fix, and I had the PCB working on my test bench in short order.

However, when I went to install it in the cabinet, I found that the power supply was in bad shape. I didn't have the parts to repair it, so I decided to replace it with one of the really nice power supplies I got from Dale Luck about 5 years ago. This turned out to be a bit of a pain because the original supply had a reset circuit which didn't behave the way most do. I tried to create a new circuit to mimic the behavior of the original, but I failed after 3 attempts. So in the end, I used a more common reset circuit design and connected it directly to the reset line of the main CPU and that worked fine.

It needed a new monitor, too. I happened to have a spare hanging around from when I bought three during a sale from Happ about a year ago.

After re-calibrating the guns, the machine works a treat! It's actually not too bad a game. It doesn't work right in MAME, so I only just got to play it for the first time when I fixed this one.


* DSCN0284.jpg (95.96 KB, 752x653 - viewed 724 times.)
« Last Edit: March 07, 2009, 04:15:32 AM by tim » Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!