ArcadeCollecting.com
Welcome, Guest. Please login or register.
June 26, 2022, 06:44:26 AM

Login with username, password and session length
Search:     Advanced search
Yay, a message board!
319 Posts in 114 Topics by 43 Members
Latest Member: deejaymc
* Home Help Search Login Register
+  ArcadeCollecting.com
|-+  General Category
| |-+  Gone but not forgotten
| | |-+  Lazarian
« previous next »
Pages: [1] Print
Author Topic: Lazarian  (Read 4792 times)
tim
Administrator
Full Member
*****
Posts: 166


View Profile
« on: November 20, 2005, 02:02:47 PM »

Company : Bally/Midway (licensor). Created by Zaccaria.
Cabinet : Dedicated
Monitor : 19" horizontal color raster



Info
Sometime in 2003, I saw a post on r.g.v.a.c. from my buddy Stephen Beall selling dedicated Lazarian and Great Guns cabinets. He said the Lazarian worked but the monitor was missing the chassis. It was a pretty rare game and the pics he had showed it had neat artwork. So I emailed him and said that I'd take both cabs for his (low) asking price if he'd drop them off at my office in Valencia, CA. I told him I was in no hurry. He agreed.

After I got the cabs, I didn't do much with the game. I just let it sit there and concentrated on getting Great Guns working instead (which I still have not succeeded at doing). Finally, in November 2005, I spotted a great deal on a new Imperial 19" color monitor from Arcade Renovations for $169 shipped. The frame was nearly a perfect match for the one in the Lazarian. I was able to move the Bally/Midway smoked monitor plexi assembly over to the new monitor with no problems. The power cord had a different type of connector than the original, but it still plugged right in and worked fine. The only other thing I had to do was move the sync wires over to one connector instead of the two different connectors it had originally. It was a simple thing to just extract the pins and stick them in the right spot.

Unfortunately, there's some kind of problem with the Lazarian PCB. Looks like the main CPU is not running as I just get a static screen full of garbage at powerup. Pulled the board and found it had a crazy weird CPU -- a S2650.

Eh, instead of trying to find tools to trouble shoot a S2650 based game, I found another PCB on eBay. Was being sold as untested but it worked when it arrived. Game works great now! What an odd game.
« Last Edit: November 19, 2008, 12:58:38 PM by tim » Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!