ArcadeCollecting.com
Welcome, Guest. Please login or register.
September 22, 2020, 06:41:13 AM

Login with username, password and session length
Search:     Advanced search
Yay, a message board!
319 Posts in 114 Topics by 43 Members
Latest Member: deejaymc
* Home Help Search Login Register
+  ArcadeCollecting.com
|-+  General Category
| |-+  Gone but not forgotten
| | |-+  Tempest
« previous next »
Pages: [1] Print
Author Topic: Tempest  (Read 2343 times)
tim
Administrator
Full Member
*****
Posts: 166


View Profile
« on: November 22, 2005, 08:50:38 PM »

Company : Atari
Cabinet : Dedicated
Monitor : 19" vertical color vector



I picked this one up in late 2003 or early 2004 from a local guy who dropped it off for me with a Q*bert.

The fella told me it was working great but that he'd install a cap kit in it for me so that I'd enjoy a long healthy time with my new Tempest. Said he'd do it that night and be over with the game the next day. Unfortunately, things didn't go so well with the cap kit and the monitor didn't work afterwards. So he only brought the Q*bert over and said he'd take the chassis on the Tempest's monitor somewhere for professional repair. A while later he emailed to let me know it was all fixed and would be over with it the next day. Sure enough, he dropped off a nice looking Tempest with a beautiful working monitor.

'Round about 2005 I moved and when I fired up the Tempest at the new place, the monitor was dead. Well, it wasn't completely dead. Every once in a while it'd flash a few of the green bits of text from the game.

It is currently awaiting my attention to diagnose and repair the problem.
« Last Edit: June 30, 2006, 02:05:05 PM by tim » Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!